Me & My Katamari Damacy Runs On v2.0!!

Katamari_2.0_1222

Today is the scheduled release day for the highly anticipated Me & My Katamari Damacy in Japan. Wayne has emailed us a great news – Katamari only requires version 2.o to run! Phew, what a relax!

With the release of EXIT, we found unfortunately that the game required version 2.50 to run. We were a bit afraid that the following games would all require 2.50 or higher to run, in the purpose of zapping the homebrew scene faster (I would say this no matter you agree or not). Now it seems the deadline has been held back a bit.

Cheers, and enjoy Katamari for PSP!! =D

Ouji_1222

Thanks to Wayne for the great email!

Check out our previous reports on Me & My Katamari Damacy:


Katamari_2.0_1222

Today is the scheduled release day for the highly anticipated Me & My Katamari Damacy in Japan. Wayne has emailed us a great news – Katamari only requires version 2.o to run! Phew, what a relax!

With the release of EXIT, we found unfortunately that the game required version 2.50 to run. We were a bit afraid that the following games would all require 2.50 or higher to run, in the purpose of zapping the homebrew scene faster (I would say this no matter you agree or not). Now it seems the deadline has been held back a bit.

Cheers, and enjoy Katamari for PSP!! =D

Ouji_1222

Thanks to Wayne for the great email!

Check out our previous reports on Me & My Katamari Damacy: